What browsers do you support? (Account Owners & Program Managers)

Header.pngTip_Icon.png

Keeping your browser up to date is the easiest way to ensure Acceptd runs properly!

--

We support several modern web browsers, but Acceptd is best optimized in the current versions of Google Chrome, Firefox, and Safari (version 10.0 or higher). Edge is also supported.

Below are links to make sure your browser is the most current version:

 

Optimized Browsers

 

Supported Browsers

 

Having technical issues? Please contact our Acceptd Support Team.

Contact_support.png

 

Footer.png

Have more questions? Submit a request

Comments

Powered by Zendesk